Updating ruby gems os x

Rated 3.98/5 based on 568 customer reviews

^ ./lib/rubygems/deprecate.rb:55: syntax error, unexpected t CONSTANT, expecting '}' ./lib/rubygems/deprecate.rb:64: syntax error, unexpected k END, expecting '}' ./lib/rubygems/deprecate.rb:69: syntax error, unexpected k END, expecting '}' from ./lib/rubygems.rb:32 from setup.rb:27:in `require' from setup.rb:27 macbook-10:rubygems-1.8.24 sergehonderdos$ gem -v 1.0.1 so that you can have multiple versions of ruby installed. I'm a regular webdesigner learning Front-End for just over a month and interested in Less/Sass.

Check out railscasts.com/episodes/200-rails-3-beta-and-rvm? view=asciic‌​ast for some guidance on updating ruby & starting with rvm. Cool; I reproduced the behavior and posted an answer below.

Another recommendation I have is to go through the first few chapters of the freely available Rails Tutorial book to gain understanding of the tools and best practices in the ruby/rails world. There might be some way to install a previous version of rubygems which is compatible with 1.8.6., but I expect that to be a complicated task.

Most ruby components would have moved ahead to be compatible with newer versions of ruby (either 1.8.7 or 1.9.3) Best way to deal with this would be to upgrade the ruby version.

If that doesn't work, download gems source again and rebuild from scratch (may want to erase prior source download, etc).

updating ruby gems os x-67

updating ruby gems os x-72

updating ruby gems os x-74

The Calabash libraries are available via the following A Ruby gem is a self-contained package that is the standard format for distributing Ruby programs and libraries.

Bulk updating Gem source index for: Bulk updating Gem source index for: ERROR: Error installing rubygems-update: rubygems-update requires builder ( Bulk updating Gem source index for: Bulk updating Gem source index for: ERROR: Error installing rubygems-update: rubygems-update requires builder ( Ruby Gems Environment: - RUBYGEMS VERSION: 1.1.1 - RUBY VERSION: 1.8.6 (2008-08-11 patchlevel 287) [universal-darwin9.0] - INSTALLATION DIRECTORY: /Library/Ruby/Gems/1.8 - RUBY EXECUTABLE: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby - RUBYGEMS PLATFORMS: - ruby - universal-darwin-9 - GEM PATHS: - /Library/Ruby/Gems/1.8 - /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8 - GEM CONFIGURATION: - :update_sources = There is no need to take such drastic steps as completely rebuilding Ruby, reinstalling Rubygems from scratch or installing a version manager to solve this problem.

There is simply a dependency cycle introduced by the release of hoe 2.3.0: rubygems-update 1.3.5 requires (among other things) hoe-seattlerb hoe-seattlerb requires hoe .

Read it in this article, which explains it very well: link text After reading it and trying a couple of times, I've seen that it was still very fuzzy/complicated.

I was trying to get the latest ruby on rails for my Mac running OS X 10.5.8.

Leave a Reply